[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Announcing xorriso-0.4.4.pl01



Hi,

be invited to try the new release 0.4.4.pl01 of my program
xorriso, a ISO 9660 Rock Ridge filesystem manipulator.

It creates, loads, manipulates and writes ISO 9660
filesystem images with Rock Ridge extensions. Optionally
it supports hard links, ACLs, xattr, and MD5 checksums.
xorriso can load the management information of existing
ISO images and it writes the session results to optical
media or to filesystem objects.
Vice versa xorriso is able to copy file objects from
ISO 9660 filesystems to disk.

A special property of xorriso is that it needs neither
an external ISO 9660 formatter program nor an external
burn program for CD, DVD or BD but rather incorporates
the libraries of libburnia-project.org .

Novelties:

* Workaround for Pioneer DVR-216D which got stuck on DVD-R burns.

* Workaround for Pioneer DVR-216D refusal to eject.


System requirements:
- Linux   : kernel 2.4 or 2.6, libc, libpthread
- FreeBSD : libc, libpthread, ATAPI/CAM enabled, see atapicam(4)
- on other X/Open systems there will be no direct operation of
  CD/DVD/BD drives, but only POSIX i/o which may or may not
  be offered by the system for DVD-RAM, DVD+RW, or BD-RE.

Optional:
  libreadline + libreadline-dev
  zlib + zlib-devel
  on Linux: libacl + libacl-devel
If they were present at compile time, then the optional libraries have to 
be present at runtime, too.


For more info, see http://scdbackup.sourceforge.net/xorriso_eng.html
                   http://scdbackup.sourceforge.net/man_1_xorriso.html

Download:

There is a xorriso release tarball (containing the application
and all three libburnia libraries needed):
  http://scdbackup.sourceforge.net/xorriso-0.4.4.pl01.tar.gz

scdbackup.sourceforge.net is mirrored at scdbackup.webframe.org .


xorriso is also part of the libisoburn release tarball:
  http://files.libburnia-project.org/releases/libisoburn-0.4.4.pl00.tar.gz
(The workaround is in libburn-0.7.2.pl01.)
  
libisoburn.so.1 and its xorriso need recent release
versions of libburn.so.4 and libisofs.so.6.
The xorriso standalone release does not depend on any
of these dynamic libraries.


Post bug reports or requests to one of these mailing lists:
  mailto:libburn-hackers@pykix.org
  mailto:cdwrite@other.debian.org
or directly to me:
  mailto:scdbackup@gmx.net


Have a nice day :)

Thomas


Reply to: