Bug#184536: apt: build dependcies cannot be satisfied when dependencies exist
In gmane.linux.debian.apt.devel, you wrote:
> In gmane.linux.debian.apt.devel, you wrote:
>> Content-Type: text/plain; charset=us-ascii
>> Content-Disposition: inline
>> Content-Transfer-Encoding: quoted-printable
>> Package: apt
>> Version: 0.5.4.9
>> Severity: important
>> When I try to run "apt-get build-dep <src-pkg>", I get an error
>> message. This makes it very difficult to build almost any package
>> automatically. I pretty sure this didn't happen with 0.5.4.
>> bmc@stonewall:/tmp/gnome-lokkit-0.50% dpkg-buildpackage -rfakeroot -us -uc
>> dpkg-buildpackage: source package is gnome-lokkit
>> dpkg-buildpackage: source version is 0.50-4
>> dpkg-buildpackage: source maintainer is Chris Lawrence <email@example.com>
>> dpkg-buildpackage: host architecture is i386
>> dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>> 3.0.0) libnewt=
>> -dev libgnome-dev automake docbook-utils
>> dpkg-buildpackage: Build dependencies/conflicts unsatisfied; aborting.
>> dpkg-buildpackage: (Use -d flag to override.)
>> bmc@stonewall:/tmp/gnome-lokkit-0.50% sudo apt-get build-dep gnome-lokkit
>> Reading Package Lists... Done
>> Building Dependency Tree... Done
>> E: Build-Depends dependency for gnome-lokkit cannot be satisfied because no=
>> available versions of package automake can satisfy version requirements
>> I'm running sid.
> If I'm not mistaken, this is not a bug in apt. If you check you will
> see the only package called automake is in stable. Sid has
> automake1.4, automake1.5, automake1.6, automake1.7. If you don't have
> stable lines in your sources.list, naturally apt is not able to fetch
> automake for you.
> I don't see any virtual package called automake either.
> I think you should reassign this as a bug in gnome-lokkit. See
> If you want to build your program, change the line in debian/control
> to one of automake1.4, automake1.5, automake1.6, automake1.7. I'd go
> with 1.4 since this is the version on stable.
I'm sorry. I'm a moron. automake1.4 etc. clearly says
So automake still exists as a virtual package. I think "apt-get
build-depends" has some problems handling virtual packages. Clearly
this bug does belong to apt. Please ignore my earlier comment.
However, it is still true if you install automake1.4 (for example) it
should take care of things for you, at least for that particular dependency.
Faheem (who needs to be more careful before posting).