Re: debuild of evolution-data-server fails
On 2010-05-07 22:17 +0200, John A. Sullivan III wrote:
> Hello, all. We are trying to rebuild the evolution-data-server package
> after patching it to hopefully end our current email nightmare. The
> base system is Lenny but we are using evolution from squeeze. When I
> try to debuild, I am getting the following errors:
> checking for GNOME_PLATFORM... configure: error: Package requirements
> (glib-2.0 >= 2.16.1
> gtk+-2.0 >= 2.14.0
I think this is the problem, since lenny has only gtk+-2.0 2.12.12. The
build dependencies in debian/control might not be correct. Note that
lenny-backports has a newer version, though.
> ORBit-2.0 >= 2.9.8
> libbonobo-2.0 >= 2.20.3
> gconf-2.0 >= 2.0.0
> libglade-2.0 >= 2.0.0
> libxml-2.0 >= 2.0.0
> libsoup-2.4 >= 2.3.0) were not met:
> Package zlib was not found in the pkg-config search path.
> Perhaps you should add the directory containing `zlib.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'zlib', required by 'GnuTLS', not found
> zlib is installed.
True, but the zlib1g-dev package in lenny does not ship a zlib.pc file;
the version in squeeze does.
> I did not check all the listed packages but the ones
> I checked were installed with the latest versions. My command sequence
> apt-get -t testing source evolution-data-server (as non-root)
> apt-get -t testing build-dep evolution-data-server (as root)
This might not do what you want. When you fetch the build dependencies
from testing, the built packages will likely also depend on libraries
not present in stable. But it appears to be impossible to build
squeeze's evolution-data-server in lenny anyway (see above).
> patched evolution-data-server
> edited debian/changelog and debian/rules (disabled gnome-key-ring - also
> tried it with this enabled as per the default)
> debuild -uc -us
> What am I doing wrong? We are rather desperate to get this running.
There are various possibilities, all not very appealing:
- Install the lenny backport of gtk+-2.0 and see what's necessary to get
the zlib.pc file into the libz1g-dev package. Resolve further build
problems by installing packages from lenny-backports or creating your
own backports. You may want to hire somebody to do the work.
- Upgrade to squeeze, deal with the ensuing breakage and hope that it
will freeze in a few months.
- use Ubuntu 10.04 or whatever current distribution has the new
evolution-data-server and deal with whatever bugs these distributions
I would go for the first option, but note that you should set
GDK_NATIVE_WINDOWS=1 in the environment if you upgrade gtk+-2.0 to
version 2.18, otherwise several applications might break¹.