Re: Etch to Lenny Upgrade Attempt
On 2009-08-29 19:47 +0200, Jason Self wrote:
> Well, I've finally decided to take the plunge and upgrade from Etch to
> Lenny, but I'm worried that it may not go well because I seem to be
> getting a warning.
> # sudo aptitude dist-upgrade
> Reading package lists... Done
> Building dependency tree... Done
> Reading extended state information
> Initializing package states... Done
> Reading task descriptions... Done
> Building tag database... Done
> The following packages are BROKEN:
> libft-perl libsasl2
These packages are not in Lenny, and apparently uninstallable there.
And libsasl2 is claimed to be a dummy package in Etch anyway.
> The following packages have unmet dependencies:
> libsasl2: Depends: libsasl2-2 (= 2.1.22.dfsg1-8+etch1) but
> 2.1.22.dfsg1-23+lenny1 is to be installed.
> libft-perl: Depends: perlapi-5.8.8 which is a virtual package.
> Resolving dependencies...
> The following actions will resolve these dependencies:
> Remove the following packages:
> Install the following packages:
> libgpm2 [1.20.4-3.1 (stable)]
> Keep the following packages at their current version:
> bash [3.1dfsg-8 (now)]
> defoma [0.11.10-0.1 (now)]
> durep [0.8.1-7 (now)]
> libio-socket-ssl-perl [1.01-1 (now)]
> libuuid1 [1.39+1.40-WIP-2006.11.14+dfsg-2etch1 (now)]
> libxml-sax-perl [0.12-5 (now)]
> mysql-server-5.0 [5.0.32-7etch10 (now)]
> openssh-client [1:4.3p2-9etch3 (now)]
> openssh-server [1:4.3p2-9etch3 (now)]
> Leave the following dependencies unresolved:
> defoma recommends libft-perl
> Score is -713
> Accept this solution? [Y/n/q/?]
I think you can go ahead. If everything goes fine, you may want to
invest why some packages had been held back, and upgrade them
individually. Another possibility is to press 'n' at the aptitude
prompt and see what other solutions it offers.