Re: mysql 5.0
Yes, My system is woody, 3.0 r4. could I apt-get upgrade, then system will be at the same level as sarge? and I could install mysql 5.0 from backport, I not very sure.
On 1/27/06, Steve Block <firstname.lastname@example.org> wrote:
On Thu, Jan 26, 2006 at 10:08:08PM +0800, linux china wrote:
>In fact, I tried both and failed,
>1) etch, I don't know how to active the suggest option, any hint?
>Get:35 ftp://ftp.linuxforum.net etch/main mysql-server-5.0 5.0.16-1 [17.1MB]
>Fetched 43.0MB in 7m8s
>E: This installation run will require temporarily removing the essential
>package e2fsprogs due to a Conflicts/Pre-Depends loop. This is often bad,
>but if you really want to do it, activate the APT::Force-LoopBreak option.
>E: Internal Error, Could not early remove e2fsprogs
>2) backport, I disabled etch, update, then issue below command again, It is
>strange that apt-get also failed.
>apt-get install mysql-server-5.0
>Reading Package Lists... Done
>Building Dependency Tree... Done
>Some packages could not be installed. This may mean that you have
>requested an impossible situation or if you are using the unstable
>distribution that some required packages have not yet been created
>or been moved out of Incoming.
>Since you only requested a single operation it is extremely likely that
>the package is simply not installable and a bug report against
>that package should be filed.
>The following information may help to resolve the situation:
>Sorry, but the following packages have unmet dependencies:
> mysql-server-5.0: Depends: mysql-client-5.0 (>= 5.0.18-3bpo1) but it is
>not going to be installed
> Depends: libdbi-perl but it is not installable
> Depends: libncurses5 (>= 5.4-1) but 5.2.20020112a-7 is
>to be installed
> Depends: libreadline5 but it is not installable
> Depends: libstdc++5 (>= 1:3.3.4-1) but it is not
>E: Sorry, broken packages
Are you using sarge? Your version of ncurses is from 2002, and is
version 5.2, but the version in sarge is
5.4-1. If you're
running woody (old stable) rather than sarge (new stable) then sarge
packages won't do you any good.
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact email@example.com