Herewith is my follow-up to the the only two responses elicited by my
request for help in installing WordPerfect 8.0 which contained
suggestions as to how to solve my problem -- those from Kent West and
First, Mr. West suggested I run "dpkg -i xlib6g.deb". I had already
tried that command before my original post. Dpkg would not install it,
saying that there were conflicting packages. As related in my original
post, installation of that package using attitude would remove 175 other
packages which I am using, including most of the kde packages.
Mr. Wiseman kindly sent me a URL with his experience in the matter. He
said that three packages would be needed: libc5, xlib6 and xpm4.7.
Package libc5 is already installed in my box, as thirteen other
packages depend on it. I found xpm4.7 in stable/oldlibs and installed
it without difficulty.
I was curious about the need to install xlib6, because the wpx-free
package, which is WordPerfect 8.0, depends not on it but on xlib6g.
However, I discovered that the book with which the Corel Linux CDROM I
have was shipped -- Corel Linux OS Starter Kit -- says on page 451 that
WordPerfect 8.0 needs xlib6 -- no mention of xlib6g. Confusing.
In any event, I discovered that xlib6 depends on xlib6g; so presumably
installation of the former will prompt installation of the latter.
Nevertheless, when I attempted to install xlib6 using attitude, I
received the following encouraging response:
< export DEBIAN_FRONTEND; apt-get install -s 'xlib6' ;echo RESULT=$?
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
xlib6: Depends: xlib6g (>= 188.8.131.52a-8) but it is not going to be
E: Broken packages
What do I do now?
Museologist, specializing in
technology and transport