seg fault on apt-get -u dist-upgrade
I had Potato running on a Ultra5. It's been sitting idle. Yesterday and
today I brought it into service as Samba server. I was reading up on NFS and
saw that rpc.rquotad did not exist. I decided to upgrade to Woody to see if
that would bring in the missing program.
I am new to apt. I think I screwed up in a big way. I was reading apt howto
and tried "apt-get -u update". It gave an "E" and did not proceed. So I
tried "apt-get -u dist-upgrade". The results are below. Then I ran the
command again - on suggestion from googling on error message. Results are
also below. I am cowardly going to reload from scratch now because it
appears that the machine is in an "in-between" state.
What I learned: Keep the machine updated more frequently.
Are there any other lessons I should be learning?
Does anyone think the problems could have been repaired by a more skilled
------ first run of apt-get -u dist-upgrade-----------
Unpacking gcc-2.95 (from .../gcc-2.95_1%3a2.95.4-7_sparc.deb) ...
Preparing to replace gcc 1:2.95.2-13 (using .../gcc_2%3a2.95.4-14_sparc.deb)
...Removing old gcc doc directory.
Unpacking replacement gcc ...
Preparing to replace cpp 1:2.95.2-13 (using .../cpp_2%3a2.95.4-14_sparc.deb)
...Unpacking replacement cpp ...
Preparing to replace g++ 1:2.95.2-13 (using .../g++_2%3a2.95.4-14_sparc.deb)
...Unpacking replacement g++ ...
Selecting previously deselected package g++-2.95.
Unpacking g++-2.95 (from .../g++-2.95_1%3a2.95.4-7_sparc.deb) ...
Preparing to replace libstdc++2.10-dev 1:2.95.2-13 (using
Unpacking replacement libstdc++2.10-dev ...
Preparing to replace libc6-dev 2.1.3-20 (using
Unpacking replacement libc6-dev ...
Replacing files in old package netbase ...
Preparing to replace locales 2.1.3-20 (using .../locales_2.2.5-11.2_all.deb)
...Unpacking replacement locales ...
E: Sub-process /usr/bin/dpkg recieved a segmentation fault.
------ second run of apt-get -u dist-upgrade-----------
sun1:/# apt-get -u dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
Sorry, but the following packages have unmet dependencies:
binutils: Depends: libc6 (>= 2.2.4-4) but 2.1.3-20 is installed
cpp-2.95: Depends: libc6 (>= 2.2.4-4) but 2.1.3-20 is installed
g++-2.95: Depends: libc6 (>= 2.2.4-4) but 2.1.3-20 is installed
gcc-2.95: Depends: libc6 (>= 2.2.4-4) but 2.1.3-20 is installed
libc6-dev: Depends: libc6 (= 2.2.5-11.2) but 2.1.3-20 is installed
libstdc++2.10-dev: Depends: libstdc++2.10-glibc2.2 (>= 1:2.95.4) but it is
locales: Depends: glibc-2.2.5-11.2
E: Unmet dependencies. Try using -f.