Re: xlibs breaking dependencies
On Sat, 2003-07-26 at 00:03, Andreas Wüst wrote:
> Am Freitag, 25.07.03, um 23:39 Uhr (Europe/Zurich) schrieb Michel
> > On Fri, 2003-07-25 at 22:50, Andreas Wüst wrote:
> >> I wanted to install some X11 related packages from sid, but they all
> >> have broken dependencies ["( ... ) but it is not going to be
> >> installed"]. So far, so good. When following those dependencies, it
> >> ultimately leads to xlibs, where it reads:
> >> xlibs (> 4.2.0) but 4.1.0-16 is to be installed
> >> Huh, I mean, what should that tell me?? If doing an apt-cache policy
> >> xlibs, there is a 4.2.1-9 install candidate, and when checking
> >> http://http.us.debian.org/debian/pool/main/x/xfree86/ there is
> >> obviously a binary available too. Furthermore, apt-get -u -t unstable
> >> install xlibs doesn't mention any problems.
> >> What is the problem? I am seeing this behaviour an all of my boxen, so
> >> it does not seem to be triggered by strange package combinations et
> >> al.
> > Hard to tell without seeing exactly what you're doing and the full
> > output.
> Hmm, well, basically I wanted to do
> # apt-get -u -t unstable install gnome-session
> on one of my boxen (which is running woody ATM). This gets me a list of
> broken dependencies, and apt-get quits. Following those deps, I end up
> everywhere on said xlibs dependency (which, to be honest, I don't
> understand, why does it want to install 4.1.0-16 when it wants a
> version greater then 4.2.0 and such a version [4.2.1-9] is even
Because you have an older version installed, and you don't tell it to
upgrade that. It works if you add xlibs on the install line, doesn't it?
Earthling Michel Dänzer \ Debian (powerpc), XFree86 and DRI developer
Software libre enthusiast \ http://svcs.affero.net/rm.php?r=daenzer