Encode >= 2.39
I'm packaging an application (the upcoming Request Tracker 4.0) which
declares a dependency on Encode >= 2.39. This is available in perl
5.12, but not 5.10, and there is no libencode-perl currently around.
I'd like to try and get RT4 installable on sid (and then squeeze, etc
via necessary backports) soon after it's released without having to
install perl 5.12 as well. The obvious way would seem to be move
libencode-perl out of attic/ and update it to the latest upstream
release and upload to unstable (or, conservatively, experimental).
Presumably we'd then also need to update perl 5.12 to add a
Replaces: for this module.
Note that this would be necessary even with perl 5.12 moved to sid,
to support backports.
Does this seem like a reasonable strategy?
Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)