Small nitpick about option names (was: RFC Debian package upgrade with Config::Model)
Sorry for the long delay. I had to put this discussion aside due to
paid workload and preparation of the French Perl Workshop (where I
presented Config::Model  )
Before plunging back in the package upgrade subject, I'd like to tackle
the smaller issue of option renaming that you suggested.
Jonas Smedegaard <firstname.lastname@example.org> writes:
>>Quite good and closer to the current keywords. I'm quite fond of
>>built_in though. May be "configfile_default" and "built_in_default" ?
> Would you mind the singleworded "builtin" instead? It seems cleaner to
> me to have it <binding>_<type> with only a single underscore.
I'm may be nitpicking, but what do you think of 'config_default' instead
of 'configfile_default'? So we'd have 'config_default' vs
After all, Config::Model could be used to configure directly an
application instead of using a configuration file. That's just a matter
of setting up a backend with IPC.
BTW, Checklist has similar default options that would become
'config_default_list' and 'builtin_default_list'.
Once this option name modification is done, I'll resume working on
package upgrade with Config::Model.
All the best
 You can already see the presentation (in French)
"Delivering successful solutions requires giving people what they
need, not what they want." Kurt Bittner
domidumont at irc.freenode.net
ddumont at irc.debian.org