(No need to Cc me if you keep -devel in the loop.) gregor herrmann <email@example.com> (21/04/2009): > On Tue, 21 Apr 2009 18:22:39 +0200, Cyril Brulebois wrote: > > > > > > libdbd-sqlite3-perl (>= 1.14), libdbi-perl (>= 1.51), perl (>= 5.6.0-12) > > > > ^^^^^^^^^^^^^^^^^^ > > > > WTH? > > > aqwa『~』$ zgrep -A1 -B1 '5.6.0-12' /usr/share/doc/dh-make-perl/changelog.gz > > > * when module has no specific perl version requirements, fall back to "perl > > > (>= 5.6.0-12)" for B-D-I, like dh_perl. Remove retrieval of (now unised) > > > information about the available perl version. > > > > Well. > > That's actually in Perl Policy, 4.4.1: > "In the absence of an explicit requirement, architecture-independent > modules must depend on a minimum perl or perl-base version of > 5.6.0-16 due to the changes in @INC introduced by that version." > http://www.debian.org/doc/packaging-manuals/perl-policy/ch-module_packages.html > > (Hm, 5.6.0-16 != 5.6.0-12.) > > (Not that it's really useful nowadays but it seems noone has bothered > about it yet ...) Hello Policy & Perl folks, can we please get rid of that obsolete version requirement? More reasons in <20090421162239.GB26779@debian.org>: http://lists.debian.org/debian-devel/2009/04/msg00792.html (Contacting -policy since that's the address given at the bottom of the perl-policy page.) Thanks for your time. Mraw, KiBi.
Description: Digital signature