Re: Bug#480256: libversion-perl: uninstallable, depends on perl (<< 5.9.0) and perlapi-5.8.8
On Fri, May 09, 2008 at 02:34:34PM +0300, Damyan Ivanov wrote:
> > The transition to perl 5.10 made libversion-perl uninstallable, due to
> > dependencies which cannot be satisfied on sid. Please rebuild/port to the
> > new perl release.
> version.pm is part of perl-modules and there is an unfortunate bug in
> the Conflicts:
> Package: perl-modules
> Version: 5.10.0-10
> Replaces: libversion-perl
> Provides: libversion-perl
> Conflicts: libversion-perl (<< 1:0.7400-2)
> That should be << 1:0.7400-3 as we have -2 already in the archive. Or
> even better, <<1:0.7401, as the version of perl-modules-provided
> version.pm is 0.7400
> Reassigning to perl-modules and bumping the urgency to important as this
> affects upgrades from Etch.
Hm, I think the real bug is the (<< 5.9.0) thing in libversion-perl. The
conflicts in perl-modules are designed to prevent an *earlier* version
of a separately packaged module to override a newer core version.
For instance, perl-modules conflicts with libmodule-build-perl
(<< 0.2808.1-1), because it contains 0.2808.1 itself. Installing the current
version of libmodule-build-perl on top of the current perl-modules isn't
broken, just useless.
The same would apply to libversion-perl without the (<< 5.9.0).
I suggest just having libversion-perl removed, it can always be
reintroduced if >0.7400 is ever released and somebody needs/wants it.
Similarly, libmodule-build-perl 0.2808.01 shouldn't be shipped with
lenny (but removing it from sid might be overkill because it's certainly
going to be updated upstream).
Stable has libversion-perl 0.6701-1, so the conflict in perl-modules
will take care of removing it on upgrades.
Sorry if I'm missing something.
Niko Tyni email@example.com