Re: Having a version of CPAN >= 1.81 ?
On Wed, Jun 13, 2007 at 09:04:27PM +0900, Charles Plessy wrote:
> Dear Perl team,
> I am trying to prepare a Debian package for BioPerl version 1.5.2, but
> the building fails with the following error:
> - ERROR: CPAN (1.76_02) is installed, but we need version >= 1.81
> Am I right if I say that CPAN in Debian belongs to perl-modules, and
> that ther is no version of this pacakge which contain a high enough
> version of CPAN ?
> If yes, do you happen to plan to prepare an update in the short-term
> future? Or shall I better upgrade locally CPAN for the moment? In that
> case, is there method which is safer than others ?
You shouldn't be using CPAN.pm to build a Debian package, I don't think,
as that is designed for automatically fetch source from remote sites.
Therefore I would suggest that you disable this functionality.
Dominic Hargreaves | http://www.larted.org.uk/~dom/
PGP key 5178E2A5 from the.earth.li (keyserver,web,email)