On Tue, Sep 09, 2003 at 04:14:35PM -0500, Kenneth Pronovici wrote:
>I asked about this on debian-perl a while ago, but didn't get any
Sorry... drowning in mail, that one must have slipped by.
>I took over libmime-base64-perl from Michael Alan Dorman around the
>beginning of July. Around the beginning of August, I received bug
>#205678, and realized that Perl 5.8.0 provides libmime-base64-perl, and
>then conflicts with libmime-base64-perl (<< 2.12-1).
>Why is there this versioned conflict? Is there any reason to maintain
>libmime-base64-perl in the archive if the base Perl package provides the
>same functionality? I'll be happy to continue maintaining the package
>(it's pretty low-maintenance, after all), but if there's no point to
>having it in the archive, I'd just as soon get rid of it before sarge
OK, the way it works is that the core Perl distribution contains a bunch
of modules (more with every release) which are also often packaged
seperately on CPAN.
Now given that Perl revisions are generally more infrequent than those
modules, it can sometimes be useful for newer versions modules which are
in the core distribution to be packaged seperately.
Since the ordering of @INC allows such packages to override the versions
provided in the perl packages I try to ensure that such versioned
conflicts are added for such packages so that we don't end up with a
module package which provides an older version that what is in perl.
So in your case, perl 5.8.0 includes version 2.12 of MIME::Base64, so
I've added a conflict for any libmime-base64-perl package earlier than
that. Since your package appears to be of 2.20, there is should be no
This module has been updated to 2.20 in the nascent 5.8.1, so when
Debian packages are released the conflict will be updated to << 2.20 .
In short, if you have reason to create a package a module of the same or
a newer version than is provided the perl packages please feel free to
do so. If your package is of the same version and does not provide
additional function, or is of an older version (in which case it will be
uninstallable anyway) please instruct the ftp masters to remove the
For more information, take a look at §3.1 of the Perl Policy document
(in the debian-policy package).
Note that one downside of this mechanism if that since versioned
provides don't work, if a particular version of an included perl module
is required then you need to do something like this:
Depends: perl (>= 5.8.0) | libmime-base64-perl (>= 2.10-1)