perl-5.6-base should conflict with all perl packages that use alternatives
Version: probably 5.6.0-6.2
Adam Heath wrote:
> Package: perl-5.6
> Severity: critical
> Perl 5.6 gets installed, removes alternative support. Then perl 5.004 gets
> installed, reinstates alternatives.
I assume that the reason perl-5.004 was installed after perl-5.6-base is
because there is a newer version of the package in sid.
Basically, perl-5.6-base needs to conflict with all earlier perl-5.004
and perl-5.005 packages because of exactly this breakage. Unfortunatly,
that may not yet be possible. If we do want to keep old perl-5.004/5
packages around, they should be updated to not try to use alternatives,
and perl-5.006-base should have a versioned conflicts with the older
versions that do use dependancies.
Since there is not actually a bug on file about this (though bod and I
have discussed it before), here goes.
see shy jo