Re: Perl mysteries.
On Mon, May 15, 2000 at 09:04:29PM +0200, Josip Rodin wrote:
> Maybe an additional Conflicts: perl-5.004-suid would work?
Why? There's no conflict there.
> > Gosh! Why do we do perl the screwed up way?
> I don't know what's the point of having two versions of perl included,
> anyway. Will anyone actually use the old version, when no modules are
> compiled against it and it might cause newer code depending on just perl5 to
- people might want to test code on perl-5.004 to see if it works
there as well as on perl-5.005 or perl-5.6. Since it is possible
to have multiple versions of perl on a machine, it would make sense
to allow it.
- if newer code needs perl-5.005, it should have a "use 5.005;" or
"require 5.005;" pragma in the code, and the package should Depend:
perl-5.005 | perl-5.6 (or whatever).
It's not obvious if there is a solution. perl-5.005 has:
Suggests: perl-5.005-suid, perl-5.005-debug, perl-5.005-doc
but you don't see that except for the first time you install the
package, and even then only when you use something like dselect to do
it. Recommends: would be too strong, and there's nothing "wrong" with
Christoph's combination of packages (perl-5.004, perl-5.004-suid,
perl-5.005) except that they don't do what's wanted: perl-5.005 won't
call suidperl-5.004. So what is the way to handle this?
Julian Gilbey, Dept of Maths, QMW, Univ. of London. J.D.Gilbey@qmw.ac.uk
Debian GNU/Linux Developer, see http://www.debian.org/~jdg
Donate free food to the world's hungry: see http://www.thehungersite.com/