Re: Bug#53794: docbook2man doesn't run at all (on examples)
reassign 53794 perl-base
severity 53794 important
retitle 53794 perl policy is flawed -- 5.004 and 5.005 simultaneous
>But wait, you're using 5.004, while this package is compiled for
>5.005. That's why the perl version you're using can't find it.
>IIRC, Perl 5.005 is now the "standard" for Debian (but I could be
>way off here). That's why we had this mess last summer when we
>were converting all the Perl modules to this version.
No, not true:
ii perl-5.004 5.004.05-3 Larry Wall's Practical Extracting and Report
ii perl-5.004-base 5.004.05-3 The Pathologically Eclectic Rubbish Lister
ii perl-5.005 5.005.03-4.1 Larry Wall's Practical Extracting and Report
ii perl-5.005-base 5.005.03-4.1 The Pathologically Eclectic Rubbish Lister
I have both installed.
>> It kinda seems that this bug should be refiled against
>I don't think this is gonna work. How about "simply" upgrading to
>5.004? Or is this not possible due to your boot floppies work?
Red herring. But that gave me a thought:
<apharris@arroz:d> ls -l /usr/bin/perl
lrwxrwxrwx 1 root root 22 Jul 8 18:55 /usr/bin/perl -> /etc/alternatives/perl
<apharris@arroz:d> ls -l /etc/alternatives/perl
lrwxrwxrwx 1 root root 19 Sep 22 10:35 /etc/alternatives/perl -> /usr/bin/perl-5.004
I mean, I know I could fix my alternatives, but is that the proper
solution? I don't think so...
If the script does have very special needs such as a specific version
of Perl then you'll need to use #!/usr/bin/perl-5.004 (I take 5.004 as
an example but you should replace 5.004 by whatever old version of
Perl you are needing) and you'll need to add a dependency to
perl-5.004. If it does furthermore request some binary modules then
you'll need to package thoses modules especially for perl-5.004
instead of the latest Perl (being perl-5.005 or whatever else). Those
modules packaged for old Perls will have to add the Perl version in
their package name. For a module Foo::Bar, instead of calling the
package libfoo-bar-perl you'll have to call it
Yet why should a script which uses a module which requires a specific
version of perl itself have to depend on that specific version of perl
-- that's not a very maintainable dependancy chain, as the above
paragraph points out.
The fact is that our perl policy is messed up -- The
libxml-parser-perl module requires perl-5.005, but there is no
guarantee that /usr/bin/perl is actually perl-5.005 -- that is managed
by /etc/alternatives, thus, it is up to the user.
I've refiled this to perl-base.
.....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>