Re: Problem about install cross compile tool on lenny
Thanks again for your kind reply.
And I'm sorry that I didn't read the difference between the testing and unstable package carefully and caused so much trouble.
I'll wait patiently until the problem can be solved.
I found that most tools on emdebian are suitable for nokia 770.
I want to cross-compile qtopia-4.2.2 on my Debian system.
Do you know any other tool which I can use to compile the source on debian package list?
Really appreciate your detailed information.
2007/5/5, Neil Williams <email@example.com>:
On Sat, 5 May 2007 10:52:54 +0800
"Kun Niu" <firstname.lastname@example.org> wrote:
> The following packages have unmet dependencies.
: Depends: libssp0 but it is not going to be
> E: Broken packages
> The gcc version on my system is 4.1.2-5.
> I wonder if it is this caused the problem.:(
You need gcc-4.1-4.1.1-21
but that means downgrading a large part of
your system. See my other email on this topic, the problem is that your
version of gcc-4.1 is RC buggy and cannot be used to create a
toolchain. A new release is pending and as soon as
gcc-4.1 builds on
arm again the toolchains can update and you (and everyone else) can
install the toolchains and the latest gcc-4.1 and glibc. Right now,
bugs in the Debian package mean that your problem cannot be solved.
> And my source.lst is like this:
> deb http://mirrors.kernel.org/debian/ unstable main non-free
http://mirrors.kernel.org/debian/ testing main non-free
> deb http://www.emdebian.org/debian/ testing main
http://www.emdebian.org/debian/ testing main
Why a mix of unstable and testing? That's what has caused your gcc-4.1
problem - you should be running the version of gcc-4.1 that is still in
) which is protected from these problems because the
RC bugs in 4.1.2-5 prevent it migrating into testing.
With this sources list, you should be able to downgrade to 4.1.1-21,
comment out the unstable source and then dist-upgrade to return to
something close to a typical Lenny installation. Until gcc-4.1 is
fixed, this is the only method of installing any cross-building
It shouldn't be long before gcc-4.1 is fixed.
> I think that I met all the requirement you mentioned.
No, your use of unstable has caused you to be using a borked gcc-4.1
that cannot support what you want: a cross-building toolchain.
> If I tried to downgrade my gcc, it seems that all software on my
> system is to be downgraded.
> It'll be really horrible.:(
It'd only be Lenny.
If that isn't acceptable, I'm afraid you will have to wait for gcc-4.1
to be fixed in Debian.