Re: Emacs snapshot/libgtk problem
I'm not sure if emacs-snapshot questions are relevant on
debian-emacsen, since the packages are not in Debian anymore. Feel
free to email me privately in case of problems.
Brendan Halpin <firstname.lastname@example.org> writes:
> I have two machines running Lenny. One has happily upgraded
> emacs-snapshot to 184.108.40.206 "(i486-pc-linux-gnu, GTK+ Version
> 2.10.13, multi-tty) of 2007-09-03 on pacem, modified by Debian".
That's an older snapshot from Sep 3rd, and GTK+ 2.12 was uploaded in
sid on Sep 20th.
> The other refuses due to a dependency on a more recent libgtk2:
> | The following packages have unmet dependencies:
> | emacs-snapshot: Depends: libgtk2.0-0 (>= 2.12.0) but 2.10.13-1 is
> | to be installed
emacs-snapshot 20070922-1 was built after GTK+ 2.12 reached
unstable, so it depends on libgtk2.0-0 (>= 2.12.0) because of a
shlibs bump. That wasn't the case for the snapshot installed on
your first machine, which is from Sep 3rd.
> Somehow the second machine will not install libgtk2.0-0 2.12.0-2,
> even with "apt-get -t unstable" insisting on 2.10.13-1.
That's the real problem. It must be trying to upgrade your whole
system including libc6, etc.
Why don't you use the etch backport instead? It should work on
lenny too (but I haven't tried).
: :' : Romain Francoise <email@example.com>
`. `' http://people.debian.org/~rfrancoise/