Re: Is adding dh_config and a postinst snippet ok ?
Joey Hess <firstname.lastname@example.org> writes:
> Installing third party debhelper commands won't break anything in
> debhelper, but nor will dh automatically call random such commands. See
> the sequence addon information in debhelper's PROGRAMMING file for
> information about adding third-party commands to dh command sequences
> (enabled via the --with switch).
> "dh_config" is a rather generic name for a third-party debhelper command
> to use. I'd generally rather reserve such names for use by debhelper,
> and have third-party command names be a bit more clearly bound to the
> package that contains them.
So, what name should I use for this dh snippet that will add
instructions to perform system configuration upgrade during package
How about dh_config_model_upgrade ? This would leave room for other dh_*
to provide alternate methods for package config upgrade...
I would also need to deliver a matching
Is this fine or too verbose ?
All the best
"Delivering successful solutions requires giving people what they
need, not what they want." Kurt Bittner
domidumont at irc.freenode.net
ddumont at irc.debian.org