Re: SASL/LDAP/DB dependency hell.
Daniel Schepler <firstname.lastname@example.org> wrote:
> Andreas Metzler <email@example.com> writes:
>> Actually it is much simpler, many packages are simply not compileable
>> libldap2-dev depends on libsasl-dev 
>> libsasl-dev depends on libdb2-dev (>= 126.96.36.199-7) 
>> libdb3-dev conflicts with libdb2-dev
>> This hits almost anything linking against libldap2, including postfix
>> (db3), apache2 (db4.1), xemacs21(db3), sendmail (db3), KDE (db4.0),
> I'm going to prepare a new NMU in which libsasl-dev has that
> dependency changed to "libdb2-dev | libdb-dev", which should satisfy
> the libtool issue while still allowing libdb4.0-dev, etc.
Thanks for giving this a shot.
> Hopefully because of the versioned symbols in libdb2 this won't
> result in breakage.
Afaik it shouldn't, it had worked so far, there are many
packages using libdb!=2 together with sasl or ldap.
> Actually, though, it seems libdb4.0 and libdb4.1 don't have versioned
> symbols -- so if a program links against -lsasl and -ldb4.0 there's
> still a possibility of problems afaict.
Iirc versioned-symbols in db2 and db3 were introduced by the
respective debian maintainers, and db4 shipped them with upstream but
my memory might be wrong.