Re: apache-ssl = perl-5.004?
On Wed, Jan 12, 2000 at 02:39:51PM -0800, Ryan White wrote:
> > dpkg --purge perl
> > or even just
> > apt-get install perl-5.005
> > All your problems will be solved....
> Not realy. I have perl-5.005 installed and working fine. The problem is
> that apache-ssl depends on perl which depends on perl-5.004-doc which
> conflicts with perl-5.005 which makes mysql short on it's perl-5.005
Huh? Do you have an up-to-date non-us packages file? Mine lists
apache-ssl with the dependencies (line-broken):
Depends: libc6 (>= 2.1), libgdbmg1, libssl09, mime-support,
apache-common (>= 1.3.9), apache-common (<< 1.3.10), perl | perl5,
openssl (>= 0.9.2b-1), libssl09 (>= 0.9.2b)
So as long as you have a package providing perl5, which you say you do
(perl-5.005), you should be able to purge perl.
BTW, packages explicitly depend upon perl-5.005 if they contain
compiled libraries; the binary format of 5.004 and 5.005 is
different. Otherwise they depend on perl5.
Julian Gilbey, Dept of Maths, QMW, Univ. of London. J.D.Gilbey@qmw.ac.uk
Debian GNU/Linux Developer, see http://www.debian.org/~jdg
Donate free food to the world's hungry: see http://www.thehungersite.com/