Bug#244344: Needs libpci1 & libpci2, aka. new pciutils breaks installs
Installing a sid system is not possible anymore because of problems
pciutils depends on libpci2 (>= 1:2.1.11-9.1); however:
Package libpci2 is not installed.
pciutils depends on libpci1; however:
Package libpci1 is not installed.
It turns out that the new version has a
Depends: libc6 (>= 2.3.2.ds1-4), libpci2 (>= 1:2.1.11-9.1), libpci1
However, debootstrap neither installs libpci2 nor libpci1. According
to the changelog of pciutils, this depends is intentional:
pciutils (1:2.1.11-10) unstable; urgency=low
* Sysfs support enabled again. libpci1 -> libpci2.
* Old shared lib in separate (source) package: libpci1
* Temporary dependency on libpci1 package, for transition purposes.
-- Remco van de Meent <firstname.lastname@example.org> Thu, 8 Apr 2004 21:07:51 +0200
So I guess debootstrap needs to include those two packages (although I
think it really sucks to install libpci1 on every new base install
just for transition purposes). (Remco, did you read the recent d-d-a
mail about not breaking base installs?)